Exit code (1) error when syncing: no changes added to commit

URL of project: Pavlovia

Description of the problem:
I’ve run into a new problem when syncing changes to the experiment. Below is a screenshot of appears in the coder output when trying to sync:

1 Like

That’s strange. I wonder why the files aren’t being added to the commit. When you press sync I assume the commit dialog does appear? Does it tell you that 4 files have changed? Are you then typing in a commit message or are you just pressing return?

Hi @jon,

I had just written an answer saying that yes the dialog appears, with the correct information about changes etc, and thought I’d just try syncing again to make sure that that is true, but now this time the sync worked. I’m 99% certain that nothing was different to how it was last time I tried syncing (yesterday evening).

Very odd, but glad that it has worked. If you plan on trying to figure out what may have been going on, let me know if you need any other info. The answer to your final question is that yes, I was typing in commit messages, but not adding ‘detailed descriptions’.

Cheers,
Anthony

Detailed description is entirely optional. A commit message of some sort is required but we added code to provide our own if the user hadn’t supplied one so all Icould think was that code had failed in your case.

Clearly there is some way to get PsychoPy to fail to add changed files during the git commit, but I’m out of ideas how that occurred. If you do see it happen again then come back and let us know (with any extra info you can think of about what might have been different).

thanks

I’m facing the same problem. I keep syncing but nothing happens, even if I add information about the changes.

git.exc.GitCommandError: Cmd(‘C:\Program Files\PsychoPy3\MinGit\cmd\git.exe’) failed due to: exit code(1)
cmdline: C:\Program Files\PsychoPy3\MinGit\cmd\git.exe commit -m new stimuli files

changed stimuli for next participant.
stdout: 'On branch master
Changes not staged for commit:
modified: “Decis\303\243o Lexical.psyexp”
modified: “html/Decis\303\243o Lexical-legacy-browsers.js”
modified: “html/Decis\303\243o Lexical.js”

no changes added to commit’

Hi, I’m also facing the same problem when trying to sync my experiment to Pavlovia. It won’t sync and it gives this error message:

Traceback (most recent call last):
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py", line 1350, in onPavloviaSync
    retVal = pavlovia_ui.syncProject(parent=self, project=self.project)
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\project.py", line 538, in syncProject
    infoStream=syncFrame)
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\functions.py", line 119, in showCommitDialog
    project.commit(commitMsg)
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\pavlovia.py", line 967, in commit
    self.repo.git.commit('-m', message)
  File "C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py", line 548, in <lambda>
    return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
  File "C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py", line 1014, in _call_process
    return self.execute(call, **exec_kwargs)
  File "C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py", line 825, in execute
    raise GitCommandError(command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd('C:\Program Files\PsychoPy\MinGit\cmd\git.exe') failed due to: exit code(1)
  cmdline: C:\Program Files\PsychoPy\MinGit\cmd\git.exe commit -m _
  stdout: 'On branch master
Changes not staged for commit:
	modified:   "MyStudy_T\303\274rk\303\247e-legacy-browsers.js"
	modified:   "MyStudy_T\303\274rk\303\247e.js"
	modified:   "MyStudy_T\303\274rk\303\247e.psyexp"
	modified:   "MyStudy_T\303\274rk\303\247e.py"
	deleted:    "MyStudy_T\303\274rk\303\247e.rar"
	modified:   "MyStudy_T\303\274rk\303\247e_lastrun.py"

no changes added to commit'

It looks like it’s caused by the files in the folder getting deleted or changed, but whatever I do, it won’t fix and I couldn’t find a solution for this. Can anyone help on how to fix this?