psychopy.org | Reference | Downloads | Github

Errors setting audioDevice preferences

Hi,

I’m using PsychoPy 1.90.2 Standalone on Windows 7 (64 Bit). We’ve encountered issues with crackling sound outputs and thus decided to buy an ASIO device, the M-AUDIO M-TRACK 2x2.
It seems to be properly recognized by PsychoPy. However, whichever entry I choose from the audioDevice drop-down list, another one is selected as soon as I close the preferences. If I start a paradigm, the following message is returned:

ERROR Requested audio device [entry different from the one I chose] that is not available on this hardware. The ‘audioDevice’ preference should be one of [u’Lautsprecher (2- M-Audio M-Trac’].

If I choose the latter, another seemingly random list entry is selected and I get the same message.
There seems to be a problem with this drop-down menu. Two other users had a similar issue, but my error message is shorter so that I decided to open a new topic.

My preferences:
audio library = [u’sounddevice’, u’pyo’, u’pygame’, ]
audio driver = [u’ASIO’, u’Audigy’, ]
audioDevice features the following entries in the drop-down list:

  • Line 1/2 (M-Audio M-Track 2X2 Out 1-2)
  • Lautsprecher (2- M-Audio M-Trac (Lautsprecher = speaker)
  • Microsoft Soundmapper - Output
  • Lautsprecher (M-Audio M-Track 2
  • default
  • Primärer Soundtreiber (= primary sound driver)
  • Lautsprecher (M-Audio M-Track 2X2)
  • M-Audio M-Track 2X2 ASIO
  • Speakers (Realtek HD Audio output)
  • Lautsprecher (2- M-Audio M-Track 2X2)

M-Audio M-Track 2X2 ASIO sounds best to me because I want to use the ASIO driver.

Any help would be greatly appreciated!

Best
Torge

Just wanted to say that this doesn’t happen anymore using PsychoPy 3 Beta 11. :slightly_smiling_face: