Error with movie stimuli in Pavlovia


I’m trying to export a task to Pavlovia, but am having trouble with getting the video components to run. Every time I create the html, an error occurs stating that there is an unexpected token in the .js files. Looking at the resulting .js files in Pavlovia, the main problem seems to be the following bit of code:

function experimentInit() {
  // Initialize components for Routine "trial"
  trialClock = new util.Clock();
  movieClock = new util.Clock();
  movie = new visual.MovieStim({
    win: psychoJS.window,
    name: 'movie', units='pix', 
    movie: 'Dot_down_15.mp4',
    pos: [0, 0],
    size: [1600, 800],
    ori: 0,
    opacity: 1,
    loop: false,
    noAudio: true,

The ‘units’ bit seems to be problematic here, as it should be units: ‘pix’ rather than units=‘pix’. I’ve tried to change this manually within the html, but when I do this another error pops up indicating the frameDur has not been defined. I think this suggests that there is a more fundamental problem when compiling the JS, but can’t find any reason why this would happen. As well as running my full task I’ve tried to create a very simple experiment with only one video stimulus, but the same errors come up with that. Has anyone come across this before/have an idea where to start with fixing this?