Error when i open psychopy

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10):
PsychoPy version (e.g. 1.84.x): v2020.2.10
Standard Standalone? (y/n) If not then what?:y
**What are you trying to achieve?:**opening it AND then a error message opens up.

**What did you try to make it work?:**i dont know what to do

What specifically went wrong when you tried that?:
Include pasted full error message if possible. “That didn’t work” is not enough information.wx._core.wxAssertionError: C++ assertion “(argtype & (wxFormatStringSpecifier::value)) == argtype” failed at C:\PROJECTS\bb2\dist-win64-py36\build\ext\wxWidgets\include\wx/strvararg.h(449) in wxArgNormalizer::wxArgNormalizer(): format specifier doesn’t match argument type

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “ctypes/callbacks.c", line 234, in ‘calling callback function’
File "C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window\win32_init
.py”, line 635, in f
event_handler = event_handlers.get(msg, None)
SystemError: <built-in method get of dict object at 0x0000021AD6D32870> returned a result with an error set

Did you recently update PsychoPy?

yes i did! infact i downloaded it for the first time. and it just keeps popping up randomly

Looks like something is going wrong with Pyglet - are you able to update your version of Pyglet specifically using pip and command line?

Hello? I would like to know if you solved it. I am having exactly the same problem and I need help. Thanks