psychopy.org | Reference | Downloads | Github

Error Message: this._.howl.loop is not a function

URL of experiment: https://run.pavlovia.org/jackyjackychan/cssl-demo/html/

Description of the problem: I experience the following message when I try to run my experiment: TypeError: this._howl.loop is not a function. The first thing that would appear on screen after the session and participant number box is an instruction page, and participants have to press the spacebar to proceed. When I press spacebar, the error message popped up and I could not proceed. Also, the screen is not showing the full instruction page, only part of it.

I wonder what is causing this, as it seems to run fine in the offline PsychoPy.

The project page is here: https://gitlab.pavlovia.org/jackyjackychan/cssl-demo.

Many thanks,
Jacky

Hi @jackyjackychan, this could be an issue using aiff files. Looking at the Howler docs it does not look like they are supported. I would convert the sound files to a supported type and try again.

Hi, many thanks for your suggestion. I’ve converted all my .aiff files to .mp3, however, the same error message pops up …

I think your Fam.xlsx conditions file still has .aiff file types in it. Try changing that, refresh your browser cache and then try again.

Well-spotted! Thanks.

I now have another issue. The familiarisation phase works fine, but after that, I see the following error message:

  • when setting the image of ImageStim: L
  • the argument: 2033 is not an image" }

I have tried changing all my picture names (e.g., 2033.png to j.png) but the exact same error message pops up even though there is no picture 2033 anymore …

Great, so looks like it was the aiff sound file format.

This is a different issue, it relates to an issue currently being fixed. If any variables in your conditions file start with numbers, they are treated as numbers. So, 2033.jpg will be converted to 2033 - we have a discussion here. For now, I suggest the fastest and easiest fix is to do the following:

  1. Add a letter to each filename in your conditions file (e.g., a2033.jpg)
  2. Go to your variables being updated in Builder, and slice off the extra letter as it is being processed. E.g., In your image component, go to the image name and slice off the first entry using $Path.slice(1).

Alternatively, change all your filenames so they do not start with numbers. You could do this with a Windows batch file - https://www.windowscentral.com/how-rename-multiple-files-bulk-windows-10

Thank you very much. I don’t know why it wouldn’t work before after I’ve renamed the images, but I tried recreating the project and it works now!

I very much appreciate your time and help.

Many thanks, Jacky