Error message appears when trying to create "new project" to run on Pavlovia from within Builder

URL of experiment: N/A

Description of the problem:

Using version 2024.1.1 of PsychoPy on Mac OS Sonoma 14.1.2.
When I tried to create a “new project” to run on Pavlovia from within the PsychoPy application, the following error message appears. This happened when I was already signed into Pavlovia in the application.

Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/ribbon.py”, line 898, in onPavloviaCreate
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.8/psychopy/app/pavlovia_ui/sync.py”, line 53, in init
AttributeError: ‘PavloviaProjectCtrl’ object has no attribute ‘session’

1 Like

Exactly the same happens to me. I managed to solve it by going under the menu “Pavlovia.org” and clicked on “Sync”, which led to a dialogue. “This project does not exists, create it now?”. By choosing yes, I was able to get a new project on Pavlovia.

(But this is obviously not how it should work…)

This worked for me too, thanks! Interestingly, it also didn’t work when I selected “new project” from the Pavlovia.org dropdown menu (so creating a new project from either of the two menus didn’t work), but clicking sync and then creating the new project after being prompted by that dialogue box did work. This also seems to have resolved other issues that I was having with running the experiment online (previously when I had successfully created a project using “new project” from the dropdown menu, I would get an error message when trying to pilot it online, but it seems to actually be working now…)

When I tried this my psychopy would crash and close all of the windows. I am not sure why though. I can reopen psychopy, try again and get the same result, or I psychopy would free after I went onto it again. Any thoughts?