Disable ESC key in pavlovia

A quick question, in builder in the exp settings i have deselected the enable esc key, however when i sync with pavlovia the esc key is active when i run the experiment. Is there something simple i am missing?

If you want to block esc in fullscreen, I don’t think it can be done. The browser will always allow people getting out of fullscreen to prevent malicious websites hijacking users’ screen. Please let me know if I’m wrong though. I’d love to know if there is a way to do it.

Hey there,

The “Enable Escape Key” should prevent the participants to abort the experiment altogether, am i wrong?

That’s the problem I got right now:
I disable the escape key on 2 out of 3 of my experiments, which works just fine (in preventing from aborting the experiment, not the fullscreen mode).
However, in the third experiment the escape button, while toggled off, still aborts the experiment…

Is there a trick to that problem? Some coherent setting that needs to be toggled?

I’m having the same issue: despite my having unchecked the “Enable Escape Key” box in Experiment Settings, when I run from Pavlovia, the escape key not only exits fullscreen when pressed once, but also terminates the experiment when pressed a second time. As far as I can see, unchecking that box had no effect at all. Has anyone found a fix for this?

I think these people are reporting that their experiment aborts when they press ESC, they seem to understand that the ESC key’s effects on fullscreen. What I understand is, they are reporting that their experiment aborts when they press ESC, despite having the key disabled.

For me, when I press ESC on my online experiments, it doesn’t abort the experiment.

My PsychoPy version is 2020.2.10

Hey everyone. Just wanted to say I added this on my list. Once I got some time left, I’ll look into it.

I think these people are reporting that their experiment aborts when they press ESC, they seem to understand that the ESC key’s effects on fullscreen. What I understand is, they are reporting that their experiment aborts when they press ESC, despite having the key disabled.

For me, when I press ESC on my online experiments, it doesn’t abort the experiment.

My PsychoPy version is 2020.2.10

Yes, that’s exactly what I meant. The behavior I desire is the one you reported.

I’m running 2021.1.3, and in that one you can disable ESC ending the experiment via Experiment Settings → Basic → Untick Enable Escape key. My guess is that any 2021.1.x version supports this, so you could give that a try.