psychopy.org | Reference | Downloads | Github

Demos run perfectly fine, but PsychoPy won't let me save or run an experiment with one text element!

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): Mac OS 10.15
PsychoPy version (e.g. 1.84.x): 3.2.3
Standard Standalone? (y/n) If not then what?:y
What are you trying to achieve?: Making any experiment run

What did you try to make it work?: I tried the demos out which worked, but whenever I try to run my own work, PsychoPy crashes.

What specifically went wrong when you tried that?: The application force closes and goes back to the desktop.
Include pasted full error message if possible.

rocess: PsychoPy3 [10017]
Path: /Applications/PsychoPy3.app/Contents/MacOS/PsychoPy3
Identifier: org.psychopy.PsychoPy3
Version: 3.2.4 (0.0.0)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: PsychoPy3 [10017]
User ID: 501

Date/Time: 2020-03-12 23:29:20.679 -0400
OS Version: Mac OS X 10.15 (19A487l)
Report Version: 12
Anonymous UUID: 4ED128CF-19DF-65DE-DB83-E28D256938F0

Sleep/Wake UUID: 6FA2F9BC-768F-493D-8EDA-6454B1420B86

Time Awake Since Boot: 450000 seconds
Time Since Wake: 11000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 PTB mainthread Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
Performing @selector(clickedAction:) from sender wxNSMenuItem 0x600002949810
abort() called
Invalid dylib load. Clients should not load the unversioned libcrypto dylib as it does not have a stable ABI.

Thread 0 Crashed:: PTB mainthread Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff65e5e5be __pthread_kill + 10
1 libsystem_pthread.dylib 0x00007fff65f1b738 pthread_kill + 203
2 libsystem_c.dylib 0x00007fff65de6a5c abort + 120
3 org.python.python 0x0000000100426551 Py_FatalError + 65
4 org.python.python 0x00000001004293ec PyGILState_Release + 108
5 _core.cpython-36m-darwin.so 0x000000010da05bf0