psychopy.org | Reference | Downloads | Github

Counterbalancing and Resource Loading

URL of experiment: Pavlovia

Description of the problem:
My experiment works when launched from Builder. On Pavlovia, however, when I click “Pilot”, the “resource loading bar” just stays white, and no actual loading happens. Despite no resources loading, I am able to press “Ok” to continue (see below):

When I hit “Ok,” my experiment goes to the first stimulus (the welcome page); however, when I click “SPACE” to continue, I get an error saying the system cannot find my conditions file (see below, alone with console error):

I know the files are uploaded to Pavlovia, as they are in my repository. The only thing I can think of that might be causing an error is the fact that I’m counterbalancing according to these instructions https://www.psychopy.org/builder/blocksCounterbalance.html. It seems like Pavlovia may not recognize that I in the conditions file field, I have a variable as “$“Order”+expInfo[‘group’]+”.xlsx". But then again, I could be wrong.

Thanks for the assistance in advance!

You need to either connect all possible resources in Builder via Experiment Settings / Online or use the download resources command in code.

@wakecarter, thanks for the response! I just tried adding all the resources to the “Online” tab in the experiment settings. I cleared the browser cache, and it still won’t work. I’m still getting the same error as above.

Use an incognito tab or different browser to double check

@wakecarter unfortunately that didn’t work either.