Color variables from CSV do not work on Pavlovia

URL of experiment: https://run.pavlovia.org/ben.s/bctest/ (it’s in pilot-mode, so most-likely not visible)

Description of the problem:
For my experiment I need a modified Flanker-task with colored squares (red, yellow, green or blue) instead of arrows. I get the flanker- and target-colors for each trial from a variable in a CSV in rgb format (for example [1,-1,-1] for red). Offline everything works fine, but on Pavlovia a get an error message saying:

Unfortunately we encountered the following error:

  • when defining a color
  • unknown named color: $farbergb
    Try to run the experiment again. If the error persists, contact the experiment designer.

I have two color variables in my CSV. One for the flankers and one for the target.
“farbergb” is the one for the target.
In the builder I put it as fill color for my rectangles as “$$farbergb” and set the update rate to “set every repeat”.
After googling around I also tried to remove one or both dollar signs, which only led to other error messages.
I also found a post, which said that you have to split the rgb value up in the three parts, but I’m not quite sure, how to implement that…
I’m not that deep into java-script so sorry if it is an easy-fixable bug and I just don’t get it.

Hope anyone can help me! Thank you!

One column for each value (farber, farbeg, farbeb)

Then set the colour in the component as $[farber, farbeg, farbeb]

Thank you so much! It now works perfectly fine!
I only have one question out of interest, maybe you can help.
When I changed the csv as you suggested, I got following error, when trying to select the it in the builder:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\dialogs_init_.py”, line 1535, in onBrowseTrialsFile
returnFieldNames=True)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\data\utils.py”, line 476, in importConditions
(fileName, len(trialList), len(fieldNames)))
UnboundLocalError: local variable ‘trialList’ referenced before assignment

I tried around and found out that this is not the case for .xlsx files, so I uploaded the xlsx to Pavlovia and it worked.
But why do I get the error with the csv? Is the data now too much for a csv file or is there any other explanation?