psychopy.org | Reference | Downloads | Github

Can't run any experiments, got a ValueError: embedded null byte

updating
I tried some methods from Internet, none of them goes well
And i think it might be some problem with the compiling function.
So i complied to a script in my laptop, using the script to run, everything works fine so far

I designed the experiments in my laptop(win10 x64) with psychopy3-3.1.0-win64-standalone, it runs fine in my laptop and my friends laptop. But when i run the experiments in my lab(win7 x86 sp1 with i3-2120 and AMD 7470) with psychopy3-3.1.0-win32-standalone. Any experiments won’t run, including the demo. So i think there must be some compatible issues. But i don’t know how to find them. here is the error messages. Thank you for your attention.

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 2127, in runFile
self.generateScript(fullPath) # Build script based on current version selected
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 2353, in generateScript
psyexpCompile.compileScript(infile=self.exp, version=None, outfile=experimentPath)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 195, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\scripts\psyexpCompile.py”, line 174, in _makeTarget
script = thisExp.writeScript(outfile, target=targetOutput)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment_experiment.py”, line 187, in writeScript
localDateTime = data.getDateStr(format="%B %d, %Y, at %H:%M")
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\data\utils.py”, line 573, in getDateStr
now = time.strftime(format, time.localtime())
ValueError: embedded null byte