Cannot run recent release on mac

I am running Catalina, v 10.15.6 OSx. I have tried downloading the standalone app for 2020.2.2 and 2020.2.3 (on GitHun). I have also tried installing from Homebrew.

In each case, the download/installation seems to work, but then running it results in the screen PsychoPy3 error with the option to either Terminate or View Console.

Am I doing something wrong? Is there something else I also need to have installed?

This is something we’re currently working on, hence it was labelled as a testing release. Catalina has added some new restrictions on applications around being codesigned and “notarized”. Parts of the application are being blocked because of that and that’s causing the whole thing to crash.

I have the same issue (the previous release .1.2 GUI doesn’t run experiments on Catalina either it just ends the exp) but I can edit them. Just wanted to note that installing the conda psychopy environment does let you run experiments (python * on Catalina (but not launch the GUI.). Would love to understand why the script will run from the terminal but not the GUI - if it can be done in 2 sentences.

Got it. Thanks for explaining it! Is there any workaround, like using an older version?

My workaround is to use the previous release (installs as .1.2 but file is named .1.3) to edit/create experiments, generate the script and run them from the conda environment. Not pretty, but functional.

Yes, previous version should run, although on some versions macOS the machine freezes for a minute while that launches (I think that’s also an issue with GateKeeper). I’m not sure why jwe080 is taking the step of compiling and then running from conda. I wasn’t aware that running studies was a problem before?

I posted herea while back. Part of the problem was that the mandatory anti-virus software Cylance was being rude, now fixed. However, libcrypto signing issues still remain and crashing persists (not fixed by softlinking to signed versions yet anyway). So now I run things from the terminal.

I am also facing the same issue. I cannot run studies on Catalina I can only make/edit scripts.


1 Like

Thanks so much Jon! (Now I just need to learn how to actually use it :slight_smile: