Cannot get experiment onto Pavlovia

OS (e.g. Win10): Win 10
PsychoPy version (e.g. 1.84.x): 3.2.5
Standard Standalone? (y/n) If not then what?: y

I get the following error when I try to make a new Pavlovia project. The program is very simple so far and runs fine in the builder, so I’m really confused. I tried rebuilding the entire project and reinstalling Psychopy. I would greatly appreciate help.
Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\”, line 161, in submitChanges
self.parent.project = self.project
AttributeError: ‘NoneType’ object has no attribute ‘project’

Does this solve your problem?

CU Jens

yes, did same think.

design new experiment on updated version of PsychoPy and no error.

Thank You

Thank You

Hi, thanks for the reply. This did not solve my problem. I previously was able to get my project onto Pavlovia, but when I tried to make a different file in the same folder everything broke. I ended up deleting the entire folder and remaking the project but I still get this error

Update: When I tried again today it, after displaying the usual error message, let me commit still for some reason, but when I try to pilot it on Pavlovia I get a 403 Forbidden error. The specific error I get is:

The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.

Update 2: Sorry for all of the updates but I think the error is stemming from using a textbox. If I remove the textbox component the program seems to run without any errors. I was really hoping I could use a textbox in my program however.

Final update: I was able to get the textbox to work by adding a padding variable and not leaving the text in the textbox blank.

1 Like