psychopy.org | Reference | Downloads | Github

Brush tool/ drawing by mouse changes behavior when adding picture stim to expriment (platform issue?)

Hi all,

Description of the problem:
I want to use the brushing tool or a corresponding mouse routine to draw on an image presented in the background. Both the brush tool as well as the mouse routine (copied from Michele Svanera / demo_drawing · GitLab) work perfectly online, as long as I do not add a picture stimulus to the experiment. However, whenever I add a picture stimulus to the experiment, I am only able to draw polygons (below left) instead of point-by-point lines (below right).

I tried changed the order of brush and picture and even (just to explore whats going on) put them in separate trials. Moreover, I used a png instead of a jpg and changes transparency. But nothing worked.

Any help would be appreciated!

Best,

Janine

I just discovered that the problem is not adding a picture stimulus, but make any changes to the demo_drawing routine, programmed using platform version 3.0.6, with the latest psychopy version. Obviously, the behavior of the brush tool and the mouse routine has changed since then. The drawing part works fine with version 3.2, but now the other parts of the experiment are causing problems. It is currently neither possible to run the full experiment from the builder (because *_lastrun.py) is not updated nor update it on Pavlovia.

I couldn’t find information about changes in the release notes relevant to my problem, does anyone know more about this?

Sorry, I don’t fully understand the problem that you were facing. Can you link to your code?