Audio playing error: beeps instead of audio sounds

OS (e.g. Win10): Win 10
**PsychoPy version: latest
**Standard Standalone? yes


I’m working on a vowel speech perception experiment with PsychoPy.
Listeners need to listen to minimal pairs containing vowel contrasts and identify the vowel they heard. Before listeners start the identification test, they can listen to 2 sample sounds thus to have a better familiarization with the vowels.

All the sample sounds play quite smoothly, but in the following formal experiment, beeps replaced original audio, and after a few beeps, one single sound file in my condition table appears again and again. No error page pops up. And by pressing the response key, I can still run the experiment.

Btw, all the sample sounds and the audio files in the following part are in two different files.

And when I play just one sound in a new experiment, the audio plays quite smoothly, and there were no beep. But when I run the previous experiment in which multiple stimuli should be present randomly, beeps replaced all the audio sounds.

All the sounds are at 44100kHz.

here is a video, which may demontrate the problem I faced more clearly

I just want to know whether this is a bug in PsychoPy or not.
And i really need help to solve this problem.
My appreciation goes to anybody who would like to help.
Looking forward to your advice as soon as possible!

Best regards,
Jessi Yu

Hey Jessi,

Are you running your experiment offline (PsychoPy) or online (PsychoJS)?

Best, Thomas

I have the same issue in PsychoJS! What is the cause of the issue?

The default sound is a beep of note C, octave 4. If something is going wrong with setting up a different sound, the code reverts to this. The reason that this happens is some issue with the design (and/or code), but this can be different per experiment. JSDoc: Source: sound/Sound.js

1 Like

This is very helpful! Thank you so much Thomas.

1 Like


Thank you so much! Thomas!

hi, guys!
Here is an update.
After I removed all the format of my excel tables, the problem was just solved.
And recently I’ve been working on recruiting participants, so I forgot to come back and check your replies immediately. Sorry for that!
And my special thanks go to Thomas, thanks for your advice!
If some of you are faced with the same problem, you can try Thomas’ approach!


1 Like