psychopy.org | Reference | Downloads | Github

AttributeError: 'NoneType' object has no attribute 'project'

Hello,

I have one question about this issue below.

When I uploaded my experiment, this issue poped up.

How can I solve the issue?

I am having the same problem. Did you ever find a solution?

For more context for others, I am trying to test out a colour space for a working memory task. It is composed of basic builder elements (shapes and a single image) loaded from an excel stimulus file. It runs fine on PsychoPy but I get this message if I try to upload to Pavlovia:

“Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\project.py”, line 161, in submitChanges
self.parent.project = self.project
AttributeError: ‘NoneType’ object has no attribute ‘project’”

Note that the upload to Pavlovia occurs – it is just that whenever I pilot the experiment nothing appears on the screen (after successfully loading in the resources). Similarly, if I test this on the local js debug I only get the “initialising the experiment…” prompt.

Any help would be appreciated.

Hi Mattk,

I think this isn’t a serious problem.
My experiment made by PsychoPy runs fine although the error message pops up.

AttributeError means that there was an Error that had to do with an Attribute request. In general, when you write x.y, y is the purported attribute of x. NoneType means that instead of an instance of whatever Class or Object you think you’re working with, you’ve actually got None. That usually means that an assignment or function call up failed or returned an unexpected result.

mylist = mylist.sort()

The sort() method of a list sorts the list in-place, that is, mylist is modified. But the actual return value of the method is None and not the list sorted. So you’ve just assigned None to mylist. If you next try to do, say, mylist.append(1) Python will give you this error.

I am also facing the same issue. I even uninstalled and installed psychopy and created the new project again. it did not work.
Please help me in solving this issue.

Thank you