AttributeError: 'NoneType' object has no attribute 'get' in eyetracking calibration

OS (e.g. Win10): Win 10
PsychoPy version (e.g. 1.84.x): 2023.2.3

I tried to connect Tobii Pro Fusion, and used just the Calibration to test. I got the following error message, ideas?

### Running: C:\Users\super\Desktop\PsychoPyExp\eye2023.2.3\ ####
pygame 2.1.0 (SDL 2.0.16, Python 3.8.10)
Hello from the pygame community.
No Tobii license_file in config. Skipping.
    *** ERROR ADDING EVENT CLASS MAPPING: Could not find class: EYE_SAMPLE = 59
Error during runSetupProcedure
Traceback (most recent call last):
  File "C:\Users\super\AppData\Roaming\psychopy3\packages\psychopy-eyetracker-tobii\psychopy_eyetracker_tobii\tobii\", line 203, in runSetupProcedure
    genv = TobiiCalibrationProcedure(self, calibration_args)
  File "C:\Users\super\AppData\Roaming\psychopy3\packages\psychopy-eyetracker-tobii\psychopy_eyetracker_tobii\tobii\", line 18, in __init__
    BaseCalibrationProcedure.__init__(self, eyetrackerInterface, calibration_args, allow_escape_in_progress=True)
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\devices\eyetracker\calibration\", line 51, in __init__
    unit_type = self.getCalibSetting('unit_type')
  File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\devices\eyetracker\calibration\", line 94, in getCalibSetting
    return calibration_args.get(setting[-1])
AttributeError: 'NoneType' object has no attribute 'get'

Hi @Jun_Fang,

Could you please share some screenshots of how you’ve entered the details of your Tobii in the Eyetracker tab of Experiment Settings?

Thanks so much,


Hi Kim,

Thanks for the reply.
The info that I put in Settings are
device: Tobii Pro Fusion
rate: 120

The other settings are optional, I have tried to put down the serial number, but still the error message.

FYI, I have tried to connect Tobii Pro Fusion with PsychoPy in the past few weeks. I have reported on PsychoPy Github page on the issues that I encountered. For example, these two issues (links below) have been resolved in the most recent release (2023.2.3). But the first issue “no such file default_eyetracker.yaml”, in the 2023.2.3 release, the yaml file is uploaded, but not in the correct directory. It should be ‘C:\Program Files\PsychoPy\lib\site-packages\psychopy\iohub\devices\eyetracker\hw\tobii\default_eyetracker.yaml’, which I manually moved the files to. Then I got another error message stated in the post.

Currently, I have downgraded to PsychoPy 2023.1.8, which is the version before making Eyetrackers as plugins. It worked fine with my experiment (with the same setting).