Anaconda install Debian 11

Hello! I have been trying to install psychopy via miniconda using the instruction on the website. I dowloaded the psychopy-env.yml file and then

conda env create -n psychopy -f psychopy-env.yml
conda activate psychopy

on top of that on my system (Debian 11) I have installed


as, if I understand correctly, some of those (probably not all) are needed.

The installation on the miniconda environment works as expected (no errors).

However when I launch “psychopy” nothing happens - not an error, not a window popping up, nothing. I tried python -m and various other similar commands but nothing pops up, nor errors are returned in the terminal…same happened when I tried installing on another machine running Manjaro and on a third machine running Fedora…anyone has any hints?! I’ve been trying to figure this out for about a week now to no avail :laughing: in the absence of any errors it’s kinda hard what’s going on here.

I made it - after two days of troubleshooting so I post the steps here if anyone is interested. I was on a freshly installed Debian 11 system and did this

sudo apt install psychopy python3-wxgtk-webview4.0
pip3 install javascripthon imageio imageio-ffmpeg pyparallel sounddevice python-bidi opencv-python moviepy glfw esprima astunparse arabic_reshaper testresources pyosf

at this point you have the debian repo version of psychopy working. It’s a bit outdated (version 2020.2.10), but hey.

At this point, if you need the latest version, this will do

pip3 install -v --user --force-reinstall
pip3 install -U psychopy
pip3 uninstall cffi
sudo apt install python3-cffi

And here you have it! The latest psychopy (2023.1.0) working as intended! The cffi version on pip is incompatible so it needs to be removed in favour of the one on the Debian repos.

I don’t know why I can’t launch it with


but instead I need to use

psychopy --builder

but it doesn’t really matter I guess. This is likely to work on Ubuntu and other debian-based distros but I have not tested it…hope this helps someone!

Quick update: on latest version I spotted quite a few problems so I’ll stick with the old version from the repo…it has all I need so I am good with that - here I just wanted to warn anyone reading this.