| Reference | Downloads | Github

After deinstalling and reinstalling, PsychoPy starts, but not with a window

After having problems with 1.85.0 (crashed), which I installed a few days before, I decided to deinstall and reinstall 1.84.2 on my Windows 7 machine. Since then, I can start PsychoPy, but after showing the logo with the message “Creating frames…”, nothing more happens. I see it in the taskbar, where all open programs appear, and I can close it from here. Multiple deinstalling and reinstalling 1.84.2 or 1.85.0 did not help either. Any hint?

Hey gernot,

First close all other windows and then try to run PsychoPy. If you place/hover your cursor(don’t click) over the PsychoPy logo in taskbar, preview windows should “popup”. If you then right click on the window you want (I assume the builder) and click maximize, it should bring the window up. You may then have to resize.

Hey b204,
thanks for the very quick answer. Unfortunately, there is only one window if I hover over the logo in the task bar. By the way, it also presents a text message referring to the last opened script in PsychoPy Coder (which is correct). As I do not have a working version of psychopy here, I am unable to veryfy wether this is expected behavior. :wink:

Try this:

If you can see the coder window (looks basically like a text editor), select View > Go to builder view (I don’t remember the exact words).

1 Like

Thanks, Daniel, for the suggestion. However, this is not the problem. I get no window at all, neither a builder, nor a coder window (actually, I use Coder, rather than Builder, and I know how to switch between them). In some sense, it probably is a Windows problem, but even though I am a Windows user for a very long time, I have no idea how to tackle this. Normally, very hard problems in Windows are finally resolved by deinstalling and reinstalling. As said, I tried this, but it did not help. Until a couple of days ago, I had a working install of PsychoPy. I updated to the very recent version, which, however, had some problems. I then decided to go back to the previous version. Not a big deal, normally. But with the reinstall of the older version, a completely new behavior emerged. Selecting PsychoPy from the start menu obviously starts the program: The logo appears, and some status messages are displayed. But instead of giving me a Coder (or maybe a Builder) view, nothing happens. PsychoPy appears in the task bar, indicating that the program is started, but there is no window, nor an obvious way select one. I might say that this is not the most daunting problem for me as I heavily use the anaconda install and code with Spyder. But the PsychoPy standalone is helpful sometimes I would appreciate having it. Any further ideas?

Well I wasn’t very clear about it but I was giving two suggestions. Just to make sure, did you try the suggestion in the linked post? Cause it sounds an awful lot like that.

Thanks again, Daniel, that did the trick, except that I had to click on maximize rather than move.

Just wanted to mention that I’ve seen this on various Windows machines (mostly Win10, one Win7 I think). For me on Win10, the “Focus; Alt+Space; M; any arrow; drop on desktop” solution worked!