403 forbidden error when trying to run experiment (Pavlovia, JSPysch)

URL of experiment: https://run.pavlovia.org/cathy-hauspie/rpep-study

Description of the problem: I get the error “403 Forbidden (nginx)” when I try to run my experiment. The console gives the error “failed to load resource: the server responded with a status of 403 ()”.

I already tried removing the old cookies from my browser, but that didn’t help. I think the error has to do with the Pavlovia & JSPsych plugins, but I’m not sure.

Thank you!

1 Like

Hi Cathy,

i had the same problem with one of my experiment. Turns out that for some reason on some versions of the experiment pavlovia fails to create a proper link for running the experiment. Try simply adding /html at the end of the link.

From: https://run.pavlovia.org/cathy-hauspie/rpep-study
To: https://run.pavlovia.org/cathy-hauspie/rpep-study/html

Worked for me!

1 Like

Thank you for your reply! When I did this, I got the error “404 not found”. Do you know how I can resolve this?

Hello Cathy

one way the get Pavlovia to generate a “new” link is to set the experiment back to inactive and then to running again.

Best Jens




Hi Jens,

I tried this too before, but the error still occurs. Thanks anyway!

Hi cathy,
I get the same error, did you find a solution ?

solved it for me, thanks Jens!!

I got this too for a new project - it’s fine for older ones. Is it to do with the nginx server load balancing config settings? Last time I got this it started working the next morning.

Sounds similar to this issue

1 Like

thanks @wakecarter - that was exactly it :slight_smile: