| Reference | Downloads | Github

403 forbidden error nginx

URL of experiment:

Description of the problem:

I am getting a 403 Forbidden error message when I try to pilot my experiment on Pavlovia. I went through several posts and made sure I have HTML, js in my github repository. Additionally, the experiment was using builder to insert custom code. All my image stimuli are JPEG. I have tried inactivate and pilot again.

At this point, I am running out of solutions. Could anyone help me with this issue?

A million thanks!

Is your experiment set to Piloting/Running?

What is the URL?

Hello Wakecarter,

Thank you very much for the prompt reply. My experiment is set to piloting, since I don’t have credit yet.

This is the piloting URL:

Do I need to have credit to pilot my experiment? I used to pilot without credit.

I can also share with your my gitlab repository, if needed. Thank you so much for the tremendous help.

The reason for your forbidden error is that you have html in the path when you shouldn’t have. Your link should be

However, it fails because it can’t load you libraries

Failed to load resource: the server responded with a status of 404 ()
/jingyi_wang/import_display/lib/data-2020.2.js:1 Failed to load resource: the server responded with a status of 404 ()
/jingyi_wang/import_display/lib/util-2020.2.js:1 Failed to load resource: the server responded with a status of 404 ()
/jingyi_wang/import_display/lib/visual-2020.2.js:1 Failed to load resource: the server responded with a status of 404 ()
/jingyi_wang/import_display/lib/sound-2020.2.js:1 Failed to load 

Thank you so much for pointing that out! I am sorry I have no idea why I have html in the path. Do you mind give me a hint about what happened?

All I did was sync using psychopy builder.
This is my experiment settings:

This is all the files I uploaded into the gitlub:

I have also tried remove the html folder. Pavlovia still gives me an 403 error. Actually one of my custom code (manually import condition files) needs me to put condition file in the html/resources folder. That is the reason I created it. I have another demo that do not have that custom code, which yield with the same 403 error.

A million thanks!

Editing folders on Gitlab directly is likely to cause issues.

You shouldn’t be manually importing from html/resources since this is dynamically created (and is no longer the default because it causes unnecessary file duplication).

Hello Wakecarter,

Thank you so much for your prompt reply. With your helpful suggestion, I delete the html folder locally and tried to create a new project in my pavlovia account. This yield with this error:

 File "C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\", line 161, in submitChanges
   self.parent.project = self.project
AttributeError: 'NoneType' object has no attribute 'project'

This remind me that everytime I tried to created a new project with this demo (not sync), it will give me this error. But after I click ok, psychopy still creates the project. Do you think this may yield with the 403 error I am getting now?

Thank you so much.

Hello Wakecarter,

Just want to update with you. You are totally right about the extra html folder. Somehow with the error that I mentioned in the above thread, my experiment worked online. One additional note I found is that this is an error with some other people. See link. If possible, do you mind help me identify the cause of this error?

Thank you so much!

1 Like