psychopy.org | Reference | Downloads | Github

2021.2.3 crashes when $ is entered

Ubuntu
v2021.2.3 via pip install

Hi there - Currently trying to create a task in builder with the newest 2021.2.3 version. However, the program crashes every time I add a ‘$’ in the text component input box to create a stimulus that updates with every repeat.

I receive this error before it crashes:
RecursionError: maximum recursion depth exceeded\

I re-downloaded an older version to test, but it works fine on that. Does anyone have any ideas of how to fix this, or this just a bug with the newest version? Thanks!

Try\$ or

$”your text including the $ with \n for new lines”

I guess @rruopp refers to this “possible bug”.

I filled an issue on github about it a fews days ago.

1 Like

What I’ve been doing as a workaround is using an old builder file as template (one in which I already had a text component with $). Curiously, you can copy and edit those without error or crash… :man_shrugging:

1 Like

Another workaround that should work is to put $msg in the text component having set msg = “Your text with $ as appropriate “ in an earlier code component.

Hi @wakecarter!

I’ve tried that…
Unfortunately, it just shows “msg” on the screen…

If you have any other thoughts, you’re more than welcome, though :slightly_smiling_face:

Hi There,

Please can I check is this when using a textBox of textStim component?

Thanks,
Becca

Hi Becca,

It is when using the testStim component, I haven’t tried textBox yet but that could be a useful work around. For the time being I am using the newest version on a Mac, and have not run into the same issue.

Hi @Becca,

It’s actually both of them.

By the way, @arnon_weinberg proposed a workaround that is simple to implement and that stops the errors and crashes.

Cheers!

2 Likes