Cannot manage to add text components witrh $ symbol

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10):
PsychoPy version (e.g. 1.84.x):
Standard Standalone? (y/n) If not then what?:
What are you trying to achieve?:

I have downloaded the procedure I have on my laptop on my lab’s computer from my GoogleDrive, and I had to take some edits to test it.

What did you try to make it work?:

In order to this, I have to add some text components with some specific code. However when I tried to add and use the $ symbol to read the text I would like to refer to, I get the following error:

What specifically went wrong when you tried that?:

Could you have possibly some workaround to fix the problem? Thanks for paying attention
Include pasted full error message if possible. “That didn’t work” is not enough information.

Is this your issue?

Yes. Just number of line differ, but this os what happens.

Anyway, I am afraid to not understanding how to cope with it. I an quite a beginnger with PsychoPy