Yaml file fails via pip


I have tried to install PsychoPy via the yaml file with Anaconda on macOS, following the instructions on the PsychoPy Website. I get the following error related to pip (after a whole stack trace of stuff).

"ModuleNotFoundError: No module named ‘dataclasses’


CondaEnvException: Pip failed"

I am using the latest macOS version, on an Intel Mac, with the latest Anaconda. I tried installation via the terminal via Visual Studio Code (latest version).

I reverted back to manually creating an environment, installing pip, then installing PsychoPy. This seems to have worked. I have run a few demos and then work fine. Not a encyclopaedic testing though.

I assume the yaml file route should have worked? Was I doing something wrong?



Edit: The manual route was all via the terminal in visual studio. So, I do not think it is a visual studio or anaconda issue per se.

hi Peter:
According to this post, the dataclasses ModuleNotFound error can be resolved with python 3.7 (or later, as I have tested and verified with v3.9 also). So if you modify the python version number (line 5) of the environment file from 3.6 to 3.7 (or above), that should fix the problem.

Awesome, thanks. This worked for me.