| Reference | Downloads | Github

Viewing participant Data from Form response

OS (e.g. Win10): 10.13.6
PsychoPy version (e.g. 1.84.x): 3
Standard Standalone? (y/n) If not then what?: y
**What are you trying to achieve?:
I am trying to use a loop through 48 images that each have the same 4 questions. I am using “Form” and it shows up on the screen with the options, but the data saves in individual excel files and only shows the “space” time press (this is how the trial is switched). I need the data to come out so that I can see participant responses, and I’m not sure why it’s not working. Further, when the screen changes to the next trial, the form is still completed the way it was on the previous screen, rather than refreshing to a blank form.

What did you try to make it work?:

I tried using the button feature from the Big5 inventory demo, but even that standalone demo doesn’t end the routine with the button press.

I have double checked that all possible data outputs are in the settings and the form item. (debug as well).

What specifically went wrong when you tried that?:

The demo doesn’t have the correct response output either (I can’t see my answers to the questions) and the button doesn’t end the trial. I downloaded another form-style experiment from this help thread on eating restraint and it also didn’t save the data appropriately, nor was there an “end” to the routine.

Thank yoU!! I can upload more detail if needed.

1 Like

I have the same problem, can anyone help on this?

Hi @Mehrnaz_Hosseinzadeh, would you mind giving more details about your issue?


I am having a similar issue on Mac OS 10.14.6; psychopy version 3
It occurs whenever I add a “form” module inside an experiment loop. Looking at the code, I think there is something wrong with the indentation in the ending routine, specifically at the while statement:

while formData[‘questions’]:

This line is backed up all the way to the left, breaking the loop. If I fix it by tabbing in coder mode, the experiment runs. However, I cannot then continue to edit the experiment in builder mode. Also, if I take out the form component, the experiment goes back to running normally.

Maybe this is a line carriage problem in the form module?