TypeError on Piloting an Experiment with Pavlovia

Hi all,
I’m new to PsychoPy/Pavlovia and would appreciate the guidance :smiley:

OS (e.g. Win10): Mac OS Ventura, Version 13.3.1
PsychoPy version (e.g. 1.84.x): 2022.2.5
Standard Standalone? (y/n) If not then what?: Y
What are you trying to achieve?:
I’m attempting to successfully pilot my experiment on pavlovia, after I had firstly successfully piloted it and discovered specific errors/forgot to make certain fixes. I synced again with the .psyexp again and it seemed to work (the addition of age/gender as demographics in the beginning) but when I press ok I see an error: * TypeError: Cannot read properties of undefined (reading ‘toString’)
What did you try to make it work?:
I used Thomas Pronk / tutorial_js_semantic_error · GitLab as a guide to try and find the mistake through the developer tab in google chrome. I found a redline in the hex.ts ( let hexString = hex.toString(16); ) and tried to find the same line in the coder file (both .js and .py) but could not find it. I also did not see the name of my experiment in the console tab as suggested by the tutorial so I’m at a loss of what to do.

What specifically went wrong when you tried that?:
Include pasted full error message if possible. “That didn’t work” is not enough information.

  • TypeError: Cannot read properties of undefined (reading ‘toString’)

Please find a screenshot of the Error with the Developer Tab.

Thanks in advance for everyones help!

I managed to avoid the problem rather than fixing it.

To elaborate, I had code in a specific routine that in two specific routines, set the window colour to black and then at the end routine tab it returned it back to the grey (watching film clips with a black window colour for a more cinema feel). However when I piloted it first, the initial code set the window colour to black for the first routine but it never returned to grey and the rest of the experiment had a black window colour.

So with all the fixes I made, I thought It would then be better to just make the entire experiment to have the window colour black. I disabled the other code components, and put a code component in the welcome screen routine, in the beginning experiment tab of the code, to make the window colour black and got the TypeError when I piloted it in pavlovia (as shown in this post).

As a test, I went back to the builder, and made the window colour black in the experiment settings and removed all the code components. I synced it again with pavlovia and this time there was no TypeError.

Is there a way to fix this problem with avoiding it?

Thanks again.