Type error: not a function - half way through experiment on Pavlovia

URL of experiment: https://run.pavlovia.org/SHUPavlovia/stroop
Description of the problem:
Hi there,
I am very new to this - I have created a stroop test on PsychoPy which runs with no issues, I have then synced this experiment to Pavlovia and it again seems to run fine but then half way through running I receive an error message saying * TypeError: word.setFlip is not a function and I am stuck at how to resolve this issue as on PsychoPy it runs all the way through no issue.

Anyone come across anything similar? Any advice would be appreciated

Let me know if any more information is needed.
All the best.

Do you have any variables, components or routines called word?
Do you have setFlip in your code?

What is supposed to happen at the point of the error?

Hi, thank you for the fast response.

Yes actually one of the routines was named word, could this be the issue?

The error comes up after the instructions for the main round of trials - it should instead lead onto to what is essentially a repeat of the practice but with more trials

Thanks again

Is word also a column title in your spreadsheet? The error suggests to me that word is being reused as something else so the easiest option would be to change the name of the routine.


word isn’t actually a title in the spreadsheet however I have now changed the routine name from word and it is still coming up with the same error at the same point in running.

Is it still saying word.setFlip or does it now give the new name for your word routine?

If the latter, please give the contents of any code in that routine.

Its actually still appearing as TypeError: word.setFlip is not a function?

Have you flushed the cache? I always reload using Ctrl-Shift-R.

You can check by making a small change to something prior to the error (e.g. putting the time into your instructions) so you know you are running the latest version.

I have flushed the cache using the method you suggested and also made a change to see if the updated version was the one running - which it now seems like it isn’t? So the changes I have made have not synced?

Are you seeing the sync icon turn green or red?

I might be looking in the wrong place as when I sync the icon to press is already green but this doesn’t change colour at any point

I use classic branding so my PsychoPy looks like this:

How long have you watched it for? It does nothing for a while, then a popup appears asking for details of the changes (if there are any), then more waiting, then it goes green, then back to normal.

Yes exactly that

So it does go green?

Once this button is pressed a box appears like you said about summary of changes the button itself doesn’t change appearance

@TParsons Hi Todd. Please could you confirm whether the sync button changes colour to indicate a successful or an unsuccessful sync when using this skin?

Hi thank you for all your help, I have been working on it and still receiving the same ‘TypeError: word setFlip is not a function’ message - it seems like the old version is interfering with the new version with the amendments as when I run it in pavlovia non of the updates are appearing.

Check on gitlab to see whether the js file being updated is in your experiment folder or an html sub folder. It could be that you are updating one and testing the other.

Hi thank you, just checked and the js file is saying last updated 1 week ago so this doesn’t seem like it has updated with the other one. How do I change this?

Thanks again for the help.