psychopy.org | Reference | Downloads | Github

The quality of sounds using sound component is not satisfying!

If this template helps then use it. If not then just delete and start from scratch.

OS : Win 10
PsychoPy version:2020.1.3
Standard Standalone? (y/n) : yes
**What are you trying to achieve?:
I want to produce sound sequences for my project.

**What specifically went wrong when you tried that?:
I’ve done it using the sound component of psychopy but the problem is that they’re not clear separate sounds. there’s some kind of buzzing sound in them.
Do you suggest using pre-created sounds and putting them in an excel file or can I fix my problem with the sound component?

You could use pre-created sounds, but if you’re just playing a particular note then that should be something Psychopy is able to do. What do you mean by “clear separate sounds”? If you need a gap between sounds, you could add a Static component

Hi @TParsons, sorry for delayed response. The main problem is not their duration as I’ve included a gap between them now. But it is that sounds are not pure sounds! I mean there’s some kind of “taq taq” sound along with the correct sound. It occurs in some sounds not in all of them but I think it’s distractive. I’ve tried it on my PC, and two other university computers, but all have this issue. It would be great if you could tell me what could be the source of this problem and how can I solve it.
Thanks you so much.

How are you specifying the sounds? By note or by Hz?

Hi @TParsons. I’ve actually tried both methods (Hz and note) and both have this issue.
In fact, what happens is that right at the moment the sound is going to finish this extra sound gets added to the sound of note!

Could you send over the .psyexp file so I can try it out myself? I think this will be easier to solve if I can try things out

Hi @TParsons. Sure!
Just a small thing! It happened a few times that at the first running the experiment it sounded good but in the second or third time, I again had that interrupting sound. So maybe it will be the case with you too.
Thank you so much.
audseq.psyexp (30.6 KB)

I can’t hear it on my device when I run your experiment, could it be to do with your sound drivers? Just going through some audiophile forums people talk about buffer size - you could try going through these steps to see if that does it:

Hi @TParsons, thank you very much for your help. Just a final thing! You said that you don’t have this problem on your system. Can I just ask you to send me a picture of Psychopy Preferences, in the hardware tab? I think that’ll help me with this issue.
Thanks again.

Sure, here are my current Hardware prefs:

I reset my preferences a lot when debugging / dealing with queries so these are just the default settings for me