psychopy.org | Reference | Downloads | Github

Stuck on "initializing experiment"

URL of experiment: Pavlovia

Description of the problem: My program worked perfect locally on PsychoPy, but it gets stuck on 'initializing experiment" when I run it on Pavlovia.

I read that import statements can cause that problem so I removed all of them, but the problem persists. I’m not sure how to find and fix the problem.

Hello,

From the link that you shared it looks like your experiment is now running and that you must have resolved your problem, please could you confirm? :slight_smile:

Thanks,
Becca

Hi, it’s partially true. The experiment now goes beyond the “initializing experiment” screen, but I get other erros.

Currently, I believe the problem is when I am using “data.importConditions” to read from my files. I get the error data not defined. I have seen some solutions where they add some JS code to the beginning of the experiment, but it doesn’t work for me as I use this in 3 different places, and I generate the name of the file randomly in that routine.

To go into more detail, this is the JS code I am referring to:

myData = new TrialHandler({

psychoJS: psychoJS,

nReps: 1, method: TrialHandler.Method.SEQUENTIAL,

extraInfo: expInfo, originPath: undefined,

trialList: ‘conditions.xlsx’,

seed: undefined, name: ‘myData’});

However, I have various trialLists and the names of the files are not ‘conditions.xlsx’

This is my code:

primeCond = randint(0, 2)
fileName = str(primeCond) + 'list.xlsx'
primeList=data.importConditions(fileName)

Thanks!

I have started a new thread for this issue if you could check that out :slightly_smiling_face::