Sound components cut short

Alright, thanks, I think I understand a little better now :blush: But is the 2020.2.10 generated fork also problematic in the same way? Is it by design that sometimes the message about the no coin animal will repeat in the background after answering what the animal position was? x

Sorry if this is naive but I thought I could only test from the master branch? I’m not sure where or how to test a version in a branch.

Is it by design that sometimes the message about the no coin animal will repeat in the background after answering what the animal position was?

Definitely should not happen, and this has never happened while I was testing it!

No worries, are you able to pilot this one? https://run.pavlovia.org/support/emotionbox/html/

Looks like not… says the pilot token is missing from URL.

I just tried changing the settings to version 2020.2.10 on my local version and pushed that to the master. Doesn’t seem like anything changed by doing that.

Hi @HEKragness, I see the version change, but it looks like 2020.2.1 instead of 2020.2.10. The pilot message you see includes a link to the experiment page, which you should be able to access because I have added your account as a fork member in the developer role. From there you can click on pilot to run the study as normal. It’s so that your project stays private even for debugging, x

Thanks, got it. I tried the support version two times and the issue persisted both times.

(For the record I actually can’t find version 2020.2.10 in the list of options of my PsychoPy settings. Afaik I have the latest version.)

By the way, the “echoing” issue during trials_2 is due to me trying to solve the issue by iterating through different sound components… but I think it would get quite complex if I used that strategy for ALL of my looped sound components throughout the experiment.

OK got it, thanks for the update. Alright, rejecting that alternate strategy makes sense, let me try digging a little deeper. Not being able to find 2020.2.10 sounds like a bug, thanks for flagging, I will be letting the Python team know.

OK I have all the information that I need. I really appreciate your patience while I work to get this fixed, s.

Sorry about the choosing 2020.2.10 as the export target again, I believe the option is further down the list.

Hm, I don’t see it!

Wow maybe I’m a version behind… I installed a new version like super recently though, in the last couple weeks. But I think that’s the only explanation. I’ll reinstall

Alrighty, I reinstalled just to make 100% sure that I was using the most updated version and still don’t see 2020.2.10 as an option.

Not that upgrading is enough to solve the problem, but yes there have been multiple PsychoPy bugfix releases in the last few weeks! The latest version is 2020.2.10. I believe your project may have been initially created using 2020.2.6. As it happens, earlier versions have no notion of targeting a later one and that I believe is the reason 2020.2.7, 2.8, or 2.9 also seem to be missing from the dropdown menu in the screenshots.

Ah, I took over the project from a collaborator so yes, it was probably created in a different version. But even if I start a new project on my most recent install (from today), versions 2020.2.7 and above still do not appear as options in the dropdown menu.

OK that then is a bug :nerd_face: and yet another bugfix release is likely imminent :yum:

Hi @HEKragness,

I believe the issue may be the coinMovie_4 component force ending the routine. Those clips are roughly two or three seconds long, not enough to allow those parallel sounds to finish. Are sounds still being cut off short in the support fork?

In terms of staging branches other than master, you basically edit GitLab’s default setting.

Also, there is a bug in PsychoJS that prevents the movie component from looping as expected. A fix for that should be pulled in very soon, but I could certainly put together a temporary solution for you if you prefer.

Best, s.

I believe the issue may be the coinMovie_4 component force ending the routine. Those clips are roughly two or three seconds long, not enough to allow those parallel sounds to finish. Are sounds still being cut off short in the support fork ?

Wow, what a silly mistake. Thanks for catching that! It did work in the support fork.

One thing I’m still puzzled about is that it doesn’t explain why me and some of my pilot testers were occasionally hearing cut-offs in the trials_2 and trials_3 loops (because “force end routine” was unchecked in those). In any case, it sure does seem it’s working fine now. I’ll make the change in my version and have a handful of people try to make sure it’s consistently working fine.

In terms of staging branches other than master, you basically edit GitLab’s default setting .

Oh coooooool! Thank you! This will be super helpful!!

Also, there is a bug in PsychoJS that prevents the movie component from looping as expected. A fix for that should be pulled in very soon, but I could certainly put together a temporary solution for you if you prefer.

Seems to be working fine for me! :slight_smile:

Thanks so much for taking a look!

:sunny: