psychopy.org | Reference | Downloads | Github

Shadowing task stops working with external sound card

Hello the PsychoPy Community,

Issue

I am running a task with participants hearing and repeating sentences. I am using the Builder of PsychoPy 64-bit Standalone v.3.2.4. on an HP laptop running Windows 10 64-bit.

The experiment works flawlessly through the integrated sound card (Realtek High Definition), from beginning to end.

The problems come when I connect my external sound card, a Steinberg UR22. The experiments does not load anymore. After I clicked on the Run button, I can enter the participant’s number. Then there is a gray screen remaining on for a few seconds. After that, I am back to the builder view as if nothing had happened.

There is no error message.

I need to run the experiment on PsychoPy 3.4.2 as I had many other problems with older versions, so I am trying hard to have the task working on this version.

What I tried

I disabled the input and output of the integrated audio while using the external sound card. The problem persists.

I checked the external card’s drivers and I verified that it works with other audio apps: with Audacity and Steinberg Cubase, the external sound card works fine (both input and output).

In Preferences>Hardware:

I check the “Audio device” case = I tried all the options, no one worked

I checked “Audio library” = it seems that there is no mention of the card’s drivers: [‘pyo’, ‘sounddevice’, ‘pyo’, ‘pygame’, ]

preferences_hw

Does anyone have an idea of how I could have PsychoPy recognize the external sound card?

Any insights would be very much appreciated!

Thank you in advance,
Dan

Hello again,

I am back with some interesting information.

The only thing that made the experiment run was to set ‘ASIO4ALL’ as ‘Audio Device’. Still, this worked only once, and what’s more there was no sound recorded.

I really hope that this will suggest a path to users who are more experienced than me.

I would very grateful for any kind of suggestion,

Thank you in advance,
Dan

Hi Dan,
I have run across a similar problem. I might not be able to help you but if what circumvented my problem comes to be useful to you then that’d be okay, I suppose.

Was the participants’ response (audio) recorded while using this integrated sound card?

I had a list of devices with similar names. So, in your case, I’d try if the ‘audio device’ is ASIO4ALL or some other name actually. I am not an expert on this, but to circumvent my problem, I had to set the device name to the name of the external speaker connected to the computer.

[By the way, is it intentional that the ‘audio driver’ is set as ‘directsound’,‘portaudio’ and not ‘Primary Sound’, or ‘ASIO’?]

All the best! :smiley:

Hi neurofreakpb,

thank you very much for taking the time to read my post and for your attempt to solve this issue. I answer your questions from paragraphs 1 to 3. In paragraph 3, there is an interesting update concerning an error message which I finally got.

Yes. With the integrated audio device, I was able to distribute audio stimuli trough the integrated speakers and to record participants’ responses through the integrated microphone. The problem appears when I connect the external soundcard Steinberg UR22; even if I disable the integrated audio device, leaving only the external sound card, the problem persists. The task does not even start; there is only a gray screen before the experiment goes back to the builder view. And I get no error message.

I went on and tried all the ‘audio device’ options, leaving all the rest the same. None configuration worked.

Thanks. I tried to follow this piece of advice but, unfortunately, it did not work.

It was not intentional; this is the way it was set after the installation.

Following your question, I made two tries. First, with only ‘Primary Sound’ set as Audio Driver. The experiment did not work.

Then, I tried setting ASIO alone as Audio Driver. With this last configuration, the experiment started, but only once! I got an error message telling that the program was unable to find a microphone (I checked the Windows settings and the mic is activated).

From the second try on, the issue was back.


Any advice would be very much appreciated as I don’t have enough experience to solve this problem. I kept reading other posts but I could not find anything which seems to fit this issue.

Thank you for your help,

Dan