Script works on one PC but not another, error message: NameError: name 'movie' is not defined

PsychoPy version (e.g. 1.84.x): 2022.2.5
Standard Standalone? (y)
What are you trying to achieve?:
I am trying to run a script that plays movies. The script runs fine on someone else’s computer so I don’t think there is a problem with the code itself. The filename for the movies is in an excel file with column title “movie”.

What did you try to make it work?:
I have tried resetting preferences in PsychoPy, reinstalling, on both a mac and Windows but both show the same error message “NameError: name ‘movie’ is not defined”.

Is the movie and the spreadsheet located in the same place on both computers?
Can you please share a screenshot of your experiment folder and spreadsheet?


Thanks very much, Chen.

I have attached screenshots of the excel sheet and the experimenter folder. I have also tried moving the MP4 files out of their respective “Objects” and “human_lowRes” folders to the same level as the excel and psyexp but the same error occurs.

Best wishes,


Can you try changing the variable named ‘movie’ to something more unique? For example, ‘display
If it doesn’t work, can you show us where you use the ‘movie’ variable?


Thanks, Chen. I tried but the error becomes “NameError: name ‘display_movie’ is not defined” instead.

Please find the script attached. The video files are too big, is there anywhere that I can upload them please?