psychopy.org | Reference | Downloads | Github

Pyo audio lib requested but not loaded

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): macOS Mojave Version 10.14.6
PsychoPy version (e.g. 1.84.x): 2020.1.2
Standard Standalone? (y) If not then what?:

The following error occurred after I loaded the new version of Psychopy and tried to run my experiment on my Mac (sorry it is not letting me copy and paste with backticks so I have to paste a screenshot below:

A couple of things to note:

  1. This same experiment worked on version 3.2.3 when I ran it on my Windows machine in my lab. I never got this error about the Pyo library not being found. Now that we are all forced to be home, I need to work on my experiment on my personal machine which is a Mac. But now, it does not work on the new version when run on my Mac.

  2. I have to use the Pyo library as my experiment has mic components and the PTB library does not support microphone components. Right?

  3. I also tried playing around with the audio driver and other hardware settings but nothing worked. Here is a picture of how the settings are now:

Thanks so much in advance for your help. I greatly appreciate it as I do not have access to my windows machine at the moment. Thanks so much Psychopy for making it possible to continue conducting experiments while we are all at home!

Best,
Maya

I am still having this issue. I do not have this issue in coder version. Is there anything else I can do?