PsychoPy won't start on Windows

I tried to clear preference and app data but it didn’t work

i wrote the strings on cmd putting the correct path and i had this traceback

C:\Users\nicbo>"C:\Program Files (x86)\PsychoPy2\python.exe" -m
Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy2\lib\", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "C:\Program Files (x86)\PsychoPy2\lib\", line 72, in _run_code
    exec code in run_globals
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\", line 96, in <module>
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\", line 28, in start_app
    app = PsychoPyApp(0, showSplash=showSplash)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\", line 175, in __init__
    self.onInit(testMode=testMode, **kwargs)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\", line 283, in onInit
    self._codeFont = wx.SystemSettings.GetFont(wx.SYS_ANSI_FIXED_FONT)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\wx-3.0-msw\wx\", line 165, in GetFont
    return _misc_.SystemSettings_GetFont(*args, **kwargs)
wx._core.PyAssertionError: C++ assertion "wxFontEnumerator::IsValidFacename(font.GetFaceName())" failed at ..\..\src\msw\settings.cpp(301) in wxSystemSettingsNative::GetFont():


that indicates an installation problem, not a pygame problem.

Best wishes Jens

Hi Jens. You mean a PsychoPy installation issue? This is on a computer that previously ran v1.90.2 (with pygame) fine. Would be interesting to know what you think the fix would be? The experiment was written in code btw, not the builder.

Incidentally, I somehow missed this from your earlier post:

update your OS. The current version is 20H2 (Build 19042.685). Your OS is lacking behind and there were some issues with PsychoPy on Windows version 1909.

That sounds like great advice, and I’ve advised @nicola_bonetti to give it a shot

In the meantime, if anybody has any thoughts on the error messages he’s received then they’d be really helpful?

Hello Sam,

ok, one way to recreate the status of the computer at the time when psychopy was running, is to use system recovery. This only works if the working status is not too long ago. Windows deletes recovery points from time to time to save disk space. Nothing that one loose all other changes to the system as well.


Best wishes Jens

psychopy in my pc has never worked.

I don’t have a backup in which psycopy was running well because it never worked.
it couldn’t even install itself.

@Sam_Leak I’ve already updated my os but it still doesn’t work

@nicola_bonetti , make a copy of the quoted file, then try replacing the file with the attached. It replaces
self._codeFont = wx.SystemSettings.GetFont(wx.SYS_ANSI_FIXED_FONT) with self._codeFont = wx.SystemSettings.GetFont(wx.SYS_DEFAULT_GUI_FONT)
which may fix the problem. Only do this if you have 1.90.2 installed. (31.2 KB)

1 Like

I did it.

The application amazingly has booted up but after 6 seconds, it closed… maybe for a crash

@nicola_bonetti what steps did you take to get it to load?

I downloaded your file and replaced it in the folder of the program.

I noticed Psychopy was in the taskbar of Windows but when i clicked, it didn’t open. so i searched for the path of the file, then I created a shortcut on my desktop and following the instructions of the experiment, I opened ‘’ with the shortcut.

psychopy booted up, it started the testing thing and opened the panel of the program. all seemed work well but after 5,6 seconds the program crashed and closed.

I repeated the process and it did the same.

FYI ‘’ is a part of my experiment, rather than a part of PsychoPy, so this might be something I can help you with. I’ll discuss this via email and if we’re still having problems then we can return to this thread. Thanks everyone!

From what I understand from @nicola_bonetti it’s PsychoPy crashing, rather than my experiment. @nicola_bonetti - can you provide further details?

I agree with @Sam_Leak , it’s a PsychoPy issue.
When I opened, it ran well. After 8 seconds Psycopy stopped working.

I repeated the same process several times and it did the same thing.

Here below, I upload the screen of the Timingcheck script running well

Thanks @nicola

I’m guessing you’ve tried running it a few times and it’s crashed on every occassion?

Can you try opening and running ‘’ and when it (presumably) crashes, can you check the ‘data_pretest’ folder for a .log file

If there’s one in there, then can you share it with us?

Failing that, perhaps someone else on here can suggest a way to produce an error message when PsychoPy fully crashes? Error messages really help us to diagnose what’s happening.

I opened “” and strangely it works well, with no bugs or crashes:
I made 2 starts, I ran the first start for about 12 seconds and the second for about 70 seconds.
In both cases the script works very well.
(I was super happy for the result of so I opened also hoping it worked but it don’t work at all.)

I’m not allowed to share .log files in the forum so I will send an email to @Sam_Leak with the files

I think I know what the problem is then, and it’s internal to the experiment rather than anything to do with PsychoPy.

In the timing check file, play around with the value of

notes_out_of_sync_by = 0.0

You’re trying to estimate with it how many notes out of sync the audio is from the text on screen.

See if that fixes things. If you can make it so that NOW appears on screen in line with the 8th note that you hear, then you’ll need to update notes_out_of_sync_by in all of the other .py files in the experiment folder too.

Unless this doesn’t work, for some reason, let’s deal with this by email rather than on the forum

it doesn’t work, it still crash as before