psychopy.org | Reference | Downloads | Github

Psychopy installation V 1.85.1


#1

Hey guys,

I’m installing psychopy on a series of lab computers in my department. I’m currently doing a test run just to see if it will work (Windows 7) so I can run a series of tests.

Unfortunately I am getting an error message when I run a practice experiment (builder view: one text stim and keyboard response).

Any fix suggestions would be greatly appreciated.

The error message is attached below.

Thanks,

Shane

Running: C:\Users\psychology\Documents\My Experiments\Practice_lastrun.py

pyo version 0.8.0 (uses single precision)
Traceback (most recent call last):
File “C:\Users\psychology\Documents\My Experiments\Practice_lastrun.py”, line 59, in
blendMode=‘avg’, useFBO=True)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\window.py”, line 364, in init
self._setupGL()
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\window.py”, line 1628, in _setupGL
self.setupPyglet()
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\window.py”, line 1482, in setupPyglet
style=style)
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\window\win32_init
.py", line 131, in init
super(Win32Window, self).init(*args, **kwargs)
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\window_init
.py", line 559, in init
self.create()
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\window\win32_init
.py", line 263, in _create
self.context.attach(self.canvas)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\pyglet\gl\win32.py”, line 210, in attach
raise gl.ContextException(‘Unable to share contexts’)
pyglet.gl.ContextException: Unable to share contexts
Exception AttributeError: “‘Window’ object has no attribute ‘useNativeGamma’” in <bound method Window.del


#2

Try updating your graphics card drivers. Google has many additional suggestions for you:

https://www.google.co.uk/search?q=pyglet.gl.ContextException%3A+Unable+to+share+contexts+psychopy&oq=pyglet.gl.ContextException%3A+Unable+to+share+contexts+psychopy&aqs=chrome..69i57.2718j0j1&sourceid=chrome&ie=UTF-8

but updating graphics card is usually the key


#3

Thanks Jon,

I will give that a run in the morning and reply.

Shane


#4

Ok, So the lab computers are running with an old Intel G41 chipset , the drivers are unavailable from the Intel website.

Looks like a case of old hardware.

Thanks for the reply Jon.

Shane


#5

These don’t work?


#6

I’ve also used the intel update assistant.

Nope, when I go to install the appropriate driver from the link above I get an error/feedback message : “The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer manufacturer. Setup will exit.”

With the latest driver update I get an error message: “This computer does not meet the minimum requirements for installing the software.”

Then I go to the manufacturers website (The PC model is a HP 500b Microtower), to get the driver update and when I install I get the same error message as above.

PC may just be a bit too old?

Shane