| Reference | Downloads | Github

Problem with running the "Hello World" demo

Hello everyone,
I’m dealing with a problem on running the “Hello World” demo. It desn’t run at all and it shows me this message on Output:

3.1569     WARNING     Monitor specification not found. Creating a temporary one...
Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\demos\coder\basic\", line 14, in <module>
    win = visual.Window()
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\", line 375, in __init__
    self.backend = backends.getBackend(win=self, *args, **kwargs)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\backends\", line 32, in getBackend
    return Backend(win, *args, **kwargs)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\visual\backends\", line 138, in __init__
AttributeError: 'PygletBackend' object has no attribute '_isFullScr'
Exception AttributeError: "'NoneType' object has no attribute 'close'" in <bound method Window.__del__ of <psychopy.visual.window.Window object at 0x05638DD0>> ignored

I think it has to do with my screen. I have a 1280*800 screen on my laptop. I found these files which are python coding and i opened them but they didn’t run. I pressed on the lines with blue colour and opened the files on the Coder view.Maybe there is a general problem on running demos that include pictures and show messages, because the “Sound Stimuli” is running without any problem.

Ps: I tried to upload the screenshots of the Coder view but i didn’t make it.
Thank you :slightly_smiling_face:

I managed to solve the problem. I went to “Preferences” and changed the “Window type” from pyglet to pygame and also clicked the ‘‘full-screen’’ button.Most of the demos are running ok!