psychopy.org | Reference | Downloads | Github

Problem to upload on Pavlovia (error 403 and don't find the file)

Good afternoon,
I tried a lot but I can’t upload my experiment (that works perfectly offline) in pavlovia. I tried to read other topics here but still I can’t and I don’t understand why.
I have always this text when I try:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 1326, in onPavloviaSync
retVal = pavlovia_ui.syncProject(parent=self, project=self.project)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py”, line 1417, in project
elif self.filename and pavlovia.getProject(self.filename):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 1096, in getProject
login(nameSpace, rememberMe=True)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 108, in login
currentSession.setToken(token)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 412, in setToken
self.startSession(token)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 437, in startSession
self.gitlab.auth()
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init_.py”, line 196, in auth
self.token_auth()
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 209, in token_auth
self.user = self.objects.CurrentUserManager(self).get()
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\exceptions.py”, line 242, in wrapped_f
return f(*args, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\mixins.py”, line 68, in get
server_data = self.gitlab.http_get(self.path, **kwargs)
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 517, in http_get
streamed=streamed, **kwargs)
File "C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init
.py", line 491, in http_request
response_body=result.content)
gitlab.exceptions.GitlabAuthenticationError: 401: 401 Unauthorized

Thank you so much if you can help me :slight_smile:

Hello,

can you login into your Pavlovia-account? Looks like an authentication error when syncing.

Best wishes Jens

1 Like

Hello,
At the end I managed to upload the experiment that the workshop of Psychopy proposed, and doing that I eliminated the files .git in the folder. But if I do the same with my experiment, I can’t and I don’t know why because it doesn’t apper any messagges or advice. I upload the file, click on pilot and just appear 403 error. Then when I check on gitlab.pavlovia, it doesn’t appear any file of my experiment and neither it.
The only messagge or error that appears is when I change from pilot to running and it’s:

unable to pull project from GitLab repository: Remote ‘origin’ has no refspec set. You can set it as follows: ‘git config --add “remote.origin.fetch +refs/heads/:refs/heads/”’.

But I’m not an informatic so I don’t know if it’s because I don’t have for now credits on pavlovia or for others problems.

Thank you in advance
Beatrice

Hello,

did you try running the suggested command git config --add “remote.origin.fetch +refs/heads/ :refs/heads/ in a command line?

As an alternative copy your experiment with its resources to another folder. Do not copy .git or .gitignore to this new folder and try to sync again.

Best wishes Jens

Hi,
I changed a few times folder and at the end it worked but not everything. Now I have all my experiment on gitlab.pavlovia, but still when I want to pilot it’s not working, it still appears 403 error but in this case if I change to running I don’t have the last command.
I try to use the link that I have when I click on running and adding /html but it’s not working.
Thank you again for the help
Beatrice