Play Sound stimulus at random intervals during a trial using conditions.xlsx file

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): macOS Catalina
PsychoPy version (e.g. 1.84.x): PsyoPy3
Standard Standalone? (y/n) If not then what?:
What are you trying to achieve?: Play sound stimulus at random intervals (in secs) durnig a trial (i.e., 6s, 7s, 8s, 9s) defined using a conditions.xlsx file.

**What did you try to make it work?: ** Created a sound object with a Start time defined using a $Stim_onset variable created within my conditions.xlsx file. The Sound was also defined using a $Stim_frex variable.

What specifically went wrong when you tried that?:
if sound_3.status == NOT_STARTED and tThisFlip >= asarray($Stim_onset)-frameTolerance:

Hi There,

Please could you tell us a bit more about the version you are using e.g. 2020.2.10 or a 2021 release (from builder click help > about)


1 Like

Sorry! Version 2021.1.0

OK a couple of bugs were ironed out following that release.

Please could you try updating to the newest release Release PsychoPy 2021.1.3 · psychopy/psychopy · GitHub and if you are still encountering a problem please share your files here :slight_smile:

Still no luck :frowning:

I have attached my files. The experiment is at its very basic level. Hoping I’ve not made a stupid mistake!


conditions.xlsx (8.6 KB) FoA (10.8 KB) FoA oddball.psyexp (6.8 KB)

I seem to have sorted it but I’m not sure why…

The experiment runs if I call the Sound “Start” without the dollar sign before the variable name but the Sound with the dollar sign before the variable name. For example, in the Start box I input “Stim” but in the Sound box I put “$Frex” to call the variables within the conditions.xlsx file.

Huh nice OK that is an interesting point I may have to raise with the dev team. The general rule of thumb is "if the parameter name has a ‘$’ already written there, you don’t need to add a $ sign at the start of the field. But I don’t think the sound field has a ‘$’ in it’s name is that correct in your version?

Yeah, it seems neither field has a dollar sign after its parameter name in my version.

OK good to know - I’ll look into it - good luck with your research!


1 Like