psychopy.org | Reference | Downloads | Github

jsPsych experiment works with Pavlovia link, but not through pilot link or locally

URL of experiment: https://run.pavlovia.org/shir/business-decision-making/

Description of the problem: I can’t seem to see my experiment online when using the piloting interface in the dashboard. I’m using the Reaction Time demo as an example here. It works using the above link, but not with https://run.pavlovia.org/shir/business-decision-making/html/, which is the link that I get when I launch the experiment through the Explore page. Further, when I run it locally, I get the following error:

[jspsych-pavlovia plugin 3.0.6] Error
when configuring the plugin
when reading the configuration file: config.json
Not Found

However, I do not get this error when I remove the code that initiates the Pavlovia connection, i.e.,:

    /* init connection with pavlovia.org */
    var pavlovia_init = {
    	type: "pavlovia",
    	command: "init"
    };
    timeline.push(pavlovia_init);

All I changed in index.html were the various filenames in the head, i.e.,:

<head>
	<title>Simple Reaction Time [jsPsych]</title>
	<meta charset="UTF-8">

	<script type="text/javascript" src="jspsych-6.1.0/jspsych.js"></script>
	<link href="jspsych-6.1.0/css/jspsych.css" rel="stylesheet" type="text/css" />

	<script type="text/javascript" src="jspsych-6.1.0/plugins/jspsych-html-keyboard-response.js"></script>
	<script type="text/javascript" src="jspsych-6.1.0/plugins/jspsych-image-keyboard-response.js"></script>

	<script type="text/javascript" src="jquery-3.4.1.min.js"></script>
	<script type="text/javascript" src="jspsych-pavlovia-3.0.6.js"></script>
</head>

Basically, I just want to be sure that the experiment I write with jsPsych will show up when I send it out through Pavlovia.

Update:

When I tried this again with a different repo/experiment, I found that it ran fine both through the Explore page and when piloting (probably because the /html/ part wasn’t added to the URL).

However, in both cases I still get the jspsych-pavlovia plugin error when running it directly from the index.html file.