Issues with Developer's Install on Windows 11 with Py 3.10

Hi all,

I’d like to contribute to the Psychopy code, but have run into issues with the Developers Install when I was ready to test my changes.

OS: Windows 11
PsychoPy version: 2022.2.4

What are you trying to achieve?
I am trying to follow the developer’s install instructions, so that I can test my changes before making a pull request.

What steps did you take/ what problems are you experiencing?
uninstalled standalone PsychoPy 2022.2.4 (didn’t want standalone to interfere with dev and vice-versa)
installed Python 3.10
followed the repo set up instructions to make my changes
in my local psychopy repo, ran pip install -e .
At this point I ran into problems, with the error ModuleNotFoundError: No module named 'fcntl'. It looks like fcntl is not available on Windows.

If I ignore this error and proceed with python C:\PATH_TO_CLONED_PSYCHOPY_REPO\psychopy\app\psychopyApp (changing PATH_TO_CLONED_PSYCHOPY_REPO to my local path), I get a ModuleNotFoundError: No module named 'psychopy', which I presume is because the previous step failed.

I am wondering if I am missing a step to get the developer’s install working on Windows?
Thanks for any suggestions,

Quick fix: Try running pip install -e . --no-deps

Real fix: fcntl is not a requirement of psychopy itself, so it must be a requirement for one of the libraries that is in psychopy’s dependencies, and there’s probably a way to circumvent just that dependency. When you get the ModuleNotFoundError does it say which dependency it was trying to install?

1 Like

Thanks for the suggestion, I tried with pip install -e . --no-deps and received the same fcntl ModuleNotFoundError (fcntl appears to be required by py2app). With this attempt I did notice a warning using user site-packages. Turns out my initial errors were due to running without admin access, which meant I wasn’t accessing the correct python site-packages for install. Running with admin access resolved these errors. Thank you for getting me on track!

This led me to new errors:

pip install -e . --no-deps was successful. When I tried to run the app with python .\psychopy\app\ I received ModuleNotFoundError: No module named 'six'. If I pip install six, the command to run the app seems to fail silently. Not sure what the solution here would be.

When attempting pip install -e . received the following error FileNotFoundError: [WinError 3] The system cannot find the path specified: 'win64dlls\\win64_pyo_data_files_common', which was triggered by attempted install of pyo. Looks like I ran into this issue because I was using Python 3.10, and pyo isn’t available there yet.

My solution:
In the end, I’ve switched to a machine where I have Python 3.8, since I now see that is the recommended Python version for pip installs (and the dev install is essentially a pip install). Here I used pip install -e . and my dev install is working.

1 Like