psychopy.org | Reference | Downloads | Github

Invalid parameter for text colour

If this template helps then use it. If not then just delete and start from scratch.

OS: Windows 10
PsychoPy version: v3.0.0b7
Standard Standalone? Yes
What are you trying to achieve?: Trying to run a basic experiment through PsychoPy. This is my first time using PsychoPy (standalone), so not sure how to fix this and was unable to find solutions that didn’t involve coding beyond my experience level.

What did you try to make it work?: Hitting the “Run” icon, saving participant/trial information.

What specifically went wrong when you tried that?:

The warning about the screen size is just that, a warning (that should be addressed at some point) but it is not an error (which would lead to your experiment stopping). [So I altered the title of your post to reflect the actual problem rather than the red herring.]

The actual error here seems to be that you have used an invalid way of specifying the colour of a text stimulus. You should check what you have entered there, and if necessary come back to us.

Colour specifications in PsychoPy are quite flexible, but check that what you are using matches one of the examples here:
http://www.psychopy.org/general/colours.html

Thank you for the feedback! After playing around with it, it appears that selecting colors by right-clicking the “Color” space and getting the rgb code doesn’t work. If I type the color in (e.g., ‘white’ or ‘blue’) then it works fine. So, maybe just stay away from rgb values.

OK, thanks, it looks like you have caught a bug. Using the RGB picker returns 4 colour values: RGB + alpha. If you just delete the last value in the list (and the preceding comma), you should get the desired colour. i.e. PsychoPy is expecting just three colour channels but receives the three colour values plus a 4th transparency value.

I’ve reported this as a bug here:

Great, thank you again!

Just to follow up: any thoughts on the screen size warning?

You need to go into the Monitor Centre (via one of the toolbar icons) and define some monitor settings that match your actual display characteristics, such as presumably 3000 × 2000 pixels and a physical size and distance. Then in the Experiment Settings dialog box, enter the name of that monitor setting (i.e. replace the default, named testMonitor, with your actual settings name).

So I had tried that earlier, though when I highlight it and click “Delete,” nothing happens.

Not sure what you mean by that. Nothing needs to be deleted. Just create a new monitor definition and use that new name in your experiment settings.