Installing on Ubuntu 22.10

I have been trying to install the latest release on Ubuntu 22.04 and now 22.10. I have even tried using pyenv to no avail, because installation always fails with this error message. Any ideas how to fix this?