ImportError: Pandas requires ver 3.0.7 or newer of openpyxl

Hi all,

I am new to PsychoPy and I have been building an experiment that uses some code components which import the pandas package. I am on macOS Ventura 13.5 and I’m running PsychoPy v2023.2.2, standalone. When I try to run this experiment, it fails and gives me this error:

ImportError: Pandas requires version '3.0.7' or newer of 'openpyxl' (version '3.0.5' currently installed).

However, I have openpyxl version 3.1.2 installed, and I’ve confirmed this in the PIP terminal using pip show openpyxl. I have also tried uninstalling and reinstalling openpyxl, and also installing specifically version 3.0.7, but I still get the same error. Why is it seeing version 3.0.5 and how do I fix this? Thanks!

Experiment file (code component using Pandas, taken from ChatGPT, is only in the first routine)
VWFA_task_psychopy.psyexp (171.1 KB)

Were you able to fix this issue? I am having the same problem and have uninstalled / reinstalled openpyxl multiple times as version 3.0.7.