I cannot hide the mouse cursor no matter what

I’m using the builder to run experiements in a local machine.
The experiment does not involve the mouse cursor.
I have a slider but I’ve customized to be controlled with keyboard responses.
So I’m trying to hide the mouse cursor all throughout the experiement.
This was easily done in the past (in different psychopy and OS versions… just speaking from experience…) but I can’t figure out why it’s not working. I would greatly appreciate any advice.

OS : Windows 11
PsychoPy version : 2023.2.3
**Standard Standalone ** : Yes
What are you trying to achieve?: hide the mouse cursor.
What did you try to make it work?:

  1. disallow GUI in preferences.
  2. uncheck ‘show mouse’ button in preferences.
  3. use code like “win.mouseVisible = False” at the beginning of the experiment.
  4. use the same code at the beginning of each routine.

What specifically went wrong when you tried that?:
Sadly, I seem to get the mouse cursor regardless of anything I try.

I have some test code for this.

https://run.pavlovia.org/test-suite/hide-mouse/

It works online with document.body.style.cursor='none'; and document.body.style.cursor='auto'; but there is currently an open issue trying to fix win.mouseVisible = False locally. I think it should work in releases prior to 2023.2

1 Like

In that case, I will either choose to roll back or wait for the next release. Thank you for your reply.