Exepriment not Running

Hi all,

I’m working on an expriment that was made on Psychopy v2021.2.3. I’ve downloaded that version to run the experiment with in my lab, but it won’t run. I am currently trying to run it on my own computer which has v2022.2.2, but I selected v2021.2.3 to use to run it. In both cases, an error box comes up that says:

Cannot run script
‘C:\Users\LizRoyalTi\Documents\EDocs\Lab\035\CortexPilotDesktopFinal_lastrun.py’, file not found!

And the following dialogue below shows up in Runner. I’m not sure what the issue here is so any help would be appreciated, thank you!

 File "C:\Users\LizRoyalTi\AppData\Local\Programs\PsychoPy\lib\runpy.py", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "C:\Users\LizRoyalTi\AppData\Local\Programs\PsychoPy\lib\runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "C:\Users\LizRoyalTi\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py", line 253, in <module>
    compileScript(args.infile, args.version, args.outfile)
  File "C:\Users\LizRoyalTi\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py", line 242, in compileScript
    thisExp = _getExperiment(infile, version)
  File "C:\Users\LizRoyalTi\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\psyexpCompile.py", line 132, in _getExperiment
    from psychopy.app.builder import experiment
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\app\builder\__init__.py", line 4, in <module>
    from ... import experiment
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\experiment\__init__.py", line 20, in <module>
    from .components import getInitVals, getComponents, getAllComponents
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\experiment\components\__init__.py", line 17, in <module>
    from ._base import BaseVisualComponent, BaseComponent
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\experiment\components\_base.py", line 19, in <module>
    from psychopy.alerts import alerttools
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\alerts\alerttools.py", line 9, in <module>
    from psychopy.visual.textbox2.fontmanager import FontManager
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\visual\__init__.py", line 29, in <module>
    from psychopy.visual.backends import gamma
  File "C:\Users\LizRoyalTi\AppData\Roaming\psychopy3\versions\psychopy\visual\backends\gamma.py", line 16, in <module>
    from psychopy.tests import _vmTesting
ModuleNotFoundError: No module named 'psychopy.tests'
279.2445     INFO     Loaded monitor calibration from ['2022_08_03 21:50']

I’m getting the same error message for version 2022.2.4 on both the standalone version and also on an install inside a Conda environment with python 3.8. I’ve also tried downgrading the Conda version to 2022.2.3 and I get the same message. I’m trying to use version 2021.2.3. I’m using OSX 12.6.

psychopy.version: 2021.2.3
pygame 2.1.2 (SDL 2.0.18, Python 3.8.1)
Hello from the pygame community. Contribute - pygame wiki
2022-11-18 14:41:07.254 python[5935:178056] ApplePersistenceIgnoreState: Existing state will not be touched. New state will be written to /var/folders/ck/77hzgwd95t998xcz4_2z_fhm0000gn/T/com.continuum.python.savedState
Traceback (most recent call last):
File “/Users/nickmartin/Documents/PycharmProjects/Cardiff/Nick_scripts/Exp1_Nov22.py”, line 10, in
from psychopy import gui, visual, core, data, event, monitors, logging, info
File “/Users/nickmartin/.psychopy3/versions/psychopy/visual/init.py”, line 31, in
from psychopy.visual.backends import gamma
File “/Users/nickmartin/.psychopy3/versions/psychopy/visual/backends/gamma.py”, line 20, in
from psychopy.tests import _vmTesting
ImportError: cannot import name ‘_vmTesting’ from ‘psychopy.tests’ (unknown location)

Hi There,

Do these related posts help? ModuleNotFoundError: No module named 'psychopy.tests'