psychopy.org | Reference | Downloads | Github

Error message: "Incorrect argument type supplied"

Hi all, my professor sent me an experiment in 3 zip files (experiment, image folder, image folder). I downloaded them all, extracted them, opened the experiment and tried to run it. It did open up to the initial gray screen for a second and then crashed displaying the following:

File “C:\Program Files\PsychoPy\lib\site-packages\psychtoolbox\hid.py”, line 145, in _create_queue
None, 0, num_slots, flags, win_handle)
TypeError: Incorrect argument type supplied

Experiment ended.

What does this mean?

This error is likely because a broken version of psychtoolbox was included with the version of the PsychoPy standalone install you are using. I’m pretty sure this has been fixed in PsychoPy 2021.2.3, the latest release.

I am using the latest version PsychoPy 2021.2.3. Unfortunately, the version that the experiment that I am trying to open/run was created on might be older. Is there any way I can still run it on my version?

Can you run any of the Builder demo’s, or do they also crash out with the same error?

I do not think using an older experiment would cause the exception you are getting, but I maybe wrong.