psychopy.org | Reference | Downloads | Github

Error 500 Pavlovia

#23

@Sweta_Parmar, that error means that there is a problem writing the JavaScript from Builder. If you share your repo with me I can have a look and see what is causing the error.

#24

Hi David,

I shared it to dvbridges account on gitlab. That’s the correct account right? Yes, while exporting html in psychopy I see error as “Failed to parse as JS by Esprima” in Windows 10 PC with 3.1.0

#25

Hi @vanessa123, I think you may need do something similar to what we tried previously. Go to command console, and change directory to C:\Program Files (x86)\Git\cmd\. Then, paste the following into your command line and press return. (If the Git folder is not in Program Files (x86) then try “Program Files”).

git config --global http.postBuffer 157286400

Give that a try, and try to sync your experiment, and let us know if it helped.

#26

Hi @Sweta_Parmar, looks like the useVersion is not writing correctly. If you set your version to blank in experiment settings, it will automatically use 3.1.0 and avoid the error where the version number is incorrectly written into the JS file.

#27

Hi @dvbridges, Thanks. This was helpful. I fixed that issue and it is working now. However, I am not able to push files if I choose a folder on the desktop. It says git will not allow this and I have to choose the “desktop” folder. Then it starts uploading my entire desktop, which takes forever and uploads fails.

#28

Hi @dvbridges,

Sorry for the late reply.

Could you please walk me through how you get to the command console?
Sorry, I realise that is a daft question. I remember you and Jon opening up a black screen and some code was showing, but I don’t know how you got there.
If I go to the start menu I can get an app called Command Prompt, but on here all it says is Microsoft Windows [Version … ] … All rights reserved.

Cheers,
Vanessa

#29

Hi @dvbridges and @jon,

I’ve shown this to my partner who has a much better understanding of computers than I do. I understand now how to reach the command console now and what you are asking me to do.

There is no Git folder in ether Program Files or in Program Files (x86).
Is there something we need to download?

Thanks for your help,
Vanessa

#30

Hi @vanessa123, try instead going to your PsychoPy directory in Program Files (x86). Then go to the MinGit folder and then the cmd folder. So, in the command console, type cd C:\Program Files (x86)\PsychoPy3\MinGit\cmd, or whatever your actual path is. Then paste the git command above into the console and press return.

#31

Thank you @dvbridges,
We have followed those changes, which all seemed to be working. The sync worked.
But when I pressed run, I came to this error message:

Unfortunately we encountered an error:

when starting the experiment
when configuring PsychoJS for the experiment
when reading the configuration file: config.json
Not Found

Do you know what this means?

Thanks, Vanessa

#32

Thanks for the error message Vanessa. Can you see all of your files on Pavlovia? @jon, can you help here with the config.json file? @vanessa123, can you post a link to your task on Pavlovia?

#33

I can see my files under the project @jon and I made the other week under the title “testONline2”.

In this one we had taken out the folders that contain the stimuli. The only files that remain are the data, html, gitignore file, and the experiment itself.
Shall I change this to also contain the folders with the stimuli in?

This is the link to the experiment https://pavlovia.org/run/lloyd-esenkaya/testonline2/html/
This is a link to the github https://gitlab.pavlovia.org/lloyd-esenkaya/testonline2

Vanessa

#34

Yes, please give that a try. I am going to have a look at uploading your task as well, to see what is happening.

#35

@vanessa123, did you have any luck getting the task to run? I was able to upload your experiment to my account and get it running. Perhaps you need a fresh project repo.

When you get the task to load in the browser, there are a couple of fixes required for playing movies, which I can help with, but will be fixed in the next PsychoPy release.

#36

Hi @dvbridges, I have made a new project repository and now have all of the files, including the stimuli, here.
I am able to sync the experiement, but running the experiment isn’t working for me. I have the error:

ReferenceError: practiseStrategies is not defined

Did this also happen for you? I have checked my file names throughout the experiment and everything looks to be in order…

This is the link to the new experiment: https://pavlovia.org/run/lloyd-esenkaya/conflictresolution_online/html/
This is the link to the new github: https://gitlab.pavlovia.org/lloyd-esenkaya/conflictresolution_online

Thanks for your help,
Vanessa

#37

While I am here, could I also ask you about these fixes that you mentioned- My other experiment is working in the browser, but I have noticed that sometimes when I run the experiment, a couple of animations can be a little bit jumpy. I wondered the fixes would cover that issue?

Thanks,
Vanessa

#38

Hi @vanessa123, yes I had some issues with movies, and so we fixed them in the latest release (download from psychopy website). For new release changelog, see:

As for jumpy videos, they seemed ok here. I was using Chrome on my laptop I had at the workshop.