psychopy.org | Reference | Downloads | Github

Conflict between PsychoPy experiment with sound and screencast application

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 2020.1.3
Standard Standalone? (y/n) If not then what?: Standalone

Today I realised a demonstration for my students, due to Sars-CoV-2 not in the lecture hall but in my homeoffice. I used Opencast (https://opencast.org/) to record a video from my presentation. When I start a PsychoPy experiment (Builder) without any sound, all works well. But when I start an experiment with sound (e.g. Sperlings partial report paradigm), the laptop’s microphone stops recording my voice as well as the PsychoPy sounds. Looks as if PsychoPy deactivates the laptop microphone when using sound.

Any advice how to not switch off the microphone when using sound?

Thanks in advance, stay safe - Sven

Probably you’re using the psychtoolbox audio backend in “Exclusive” mode. This gives optimal timing while also allowing any sampling rate. In the non-exclusive modes you’ll either get poor timing (not exclusive so resampling sounds to fit the 44khz sampling rate of the stream) or you’ll have to use 44000 sampling rate only I believe (because that’s the default sampling rate of the stream). Experiment settings allows you to control the mode you’re in.

Hi Jon,
thanks for your reply. Yes, I was running Psychopy with the audio backend in mode 4. Changing to mode 1 solved my problem. Thank you very much for your help AND FOR PSYCHOPY.

Kind regards - Sven