psychopy.org | Reference | Downloads | Github

Can't load Psychopy modules from Spyder even after pythonpathing

As the title goes, I am unable to get psychopy modules loaded on the spyder 3 (via the latest anaconda package) platform. This has nothing to do with loading the wrong module as the script works fine on my other computers. The psychopy version I am using is 1.85.4.

The current guide states that the two paths that need to be added to pythonpath path are:

[psychopy-folder]\Lib\site-package

[psychopy-folder]\Lib\site-packages\psychopy[version].egg

I have done the first, but there isn’t any .egg file for the 1.85.4 version. Not sure if this file is missing from the standalone installation package, or that there is a new implementation that I am not aware of.

Also, I have installed both psychopy and anaconda on a separate empty drive (ie. D drive and not C) that is not with the main system. Could that also lead to some sort of problem as well?

Update: So I tried to use the manual pathing method instead using import sys within the script itself and it worked with the Anaconda package2 4.0.0 windows x86_64 package but not with the most recent 5.0.1 x86_64 package. Just a note to Spyder users out there.

Also, spyder defined python pathing resulted in “An error occurred while starting the kernel”, which I am not quite sure what is causing this.