Cannot run experiment online

URL of experiment: Pavlovia

Description of the problem: Doesn’t advance beyond “initialising the experiment…” message.

I can run it locally in python.

This tutorial might help: Thomas Pronk / tutorial_js_syntax_error · GitLab

Thank you for the info. I looked in the console and the error reported is as follows:

CorrectionOfFakeNews.js:177 Uncaught SyntaxError: Unexpected token ‘*’

It appears that line is:

import * as re from ‘re’;

It updated the experiment to do the import at the beginning of the experiment, but nothing seems to change, the same error is reported when I run it again. It seems that it runs the old code all the time.

I haven’t heard of re but you can’t import Python libraries.

re is python’s regexp implementation and I used it to match specific expressions. I use a code stimulus in the builder and I used Python. The auto translation to JS didn’t complain about importing re.
So I removed that, sync’ed w/the repo, but when I pilot again it runs the same old version. How can I clean up the tokens so it generates a new one w/the updated code?

As per my crib sheet you can try Ctrl-Shift-R to flush the cache.